using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?)[?=-](.+?)[?=-](.+?)[?=.](.+?$)";
string input = @"US-LegolandFlorida-ScreenLineup.csv
US-39148-Floor6_S1-Lineup.csv
US-39148-Floor6_S1-Disclaimers.csv
US-39148-S3-Lineup.csv
US-39148-S3-Disclaimers.csv
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}