package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+?)[?=-](.+?)[?=-](.+?)[?=.](.+?$)`)
var str = `US-LegolandFlorida-ScreenLineup.csv
US-39148-Floor6_S1-Lineup.csv
US-39148-Floor6_S1-Disclaimers.csv
US-39148-S3-Lineup.csv
US-39148-S3-Disclaimers.csv
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}