re = /(.+?)[?=-](.+?)[?=-](.+?)[?=.](.+?$)/m
str = 'US-LegolandFlorida-ScreenLineup.csv
US-39148-Floor6_S1-Lineup.csv
US-39148-Floor6_S1-Disclaimers.csv
US-39148-S3-Lineup.csv
US-39148-S3-Disclaimers.csv
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end