# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\p{Ll}+)(\p{Lu}\p{Ll}*)/$1. $2/g;t' <<< "She has an excellent command on the topicsOnly problem is clarity in EnglishHer confidence is very good in RUSSian and H2O"