using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\p{Ll}+)(\p{Lu}\p{Ll}*)";
string substitution = @"$1. $2";
string input = @"She has an excellent command on the topicsOnly problem is clarity in EnglishHer confidence is very good in RUSSian and H2O";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}