use strict;
my $str = 'She has an excellent command on the topicsOnly problem is clarity in EnglishHer confidence is very good in RUSSian and H2O';
my $regex = qr/(\p{Ll}+)(\p{Lu}\p{Ll}*)/p;
my $subst = '$1. $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";