$re = '/(\p{Ll}+)(\p{Lu}\p{Ll}*)/';
$str = 'She has an excellent command on the topicsOnly problem is clarity in EnglishHer confidence is very good in RUSSian and H2O';
$subst = "$1. $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;