package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\p{Ll}+)(\p{Lu}\p{Ll}*)`)
var str = `She has an excellent command on the topicsOnly problem is clarity in EnglishHer confidence is very good in RUSSian and H2O`
var substitution = "$1. $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}