#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\p{Ll}+)(\p{Lu}\p{Ll}*)"
Local $sString = "She has an excellent command on the topicsOnly problem is clarity in EnglishHer confidence is very good in RUSSian and H2O"
Local $sSubst = "$1. $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)