import Foundation
let pattern = #"(\p{Ll}+)(\p{Lu}\p{Ll}*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"She has an excellent command on the topicsOnly problem is clarity in EnglishHer confidence is very good in RUSSian and H2O"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1. $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)