import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(href|src)=\"((https*:\\/\\/)([\\w\\d\\.]+))*\\/([\\w\\d\\/]+)\\.(jpg|jpeg|png|gif)";
final String string = "href=\"http://example.com/_pu/0/filename.jpg\"\n"
+ "href=\"https://example.com/_pu/0/filename.jpg\"\n"
+ "href=\"/_pu/0/filename.jpg\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}