$re = '/(href|src)="((https*:\/\/)([\w\d\.]+))*\/([\w\d\/]+)\.(jpg|jpeg|png|gif)/m';
$str = 'href="http://example.com/_pu/0/filename.jpg"
href="https://example.com/_pu/0/filename.jpg"
href="/_pu/0/filename.jpg"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);