import Foundation
let pattern = #"(href|src)="((https*:\/\/)([\w\d\.]+))*\/([\w\d\/]+)\.(jpg|jpeg|png|gif)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
href="http://example.com/_pu/0/filename.jpg"
href="https://example.com/_pu/0/filename.jpg"
href="/_pu/0/filename.jpg"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)