import re
regex = re.compile(r"(href|src)=\"((https*:\/\/)([\w\d\.]+))*\/([\w\d\/]+)\.(jpg|jpeg|png|gif)", flags=re.MULTILINE)
test_str = ("href=\"http://example.com/_pu/0/filename.jpg\"\n"
"href=\"https://example.com/_pu/0/filename.jpg\"\n"
"href=\"/_pu/0/filename.jpg\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")