// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(href|src)="((https*:\/\/)([\w\d\.]+))*\/([\w\d\/]+)\.(jpg|jpeg|png|gif)"#).unwrap();
let string = "href=\"http://example.com/_pu/0/filename.jpg\"
href=\"https://example.com/_pu/0/filename.jpg\"
href=\"/_pu/0/filename.jpg\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}