re = /(href|src)="((https*:\/\/)([\w\d\.]+))*\/([\w\d\/]+)\.(jpg|jpeg|png|gif)/m
str = 'href="http://example.com/_pu/0/filename.jpg"
href="https://example.com/_pu/0/filename.jpg"
href="/_pu/0/filename.jpg"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end