using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"get_aval_stock\s*\(\s*.*\s*,\s*.*\s*,\s*.*\s*,\s*.*\s*,\s*'[ANOPZ]'\s*.*\)";
string input = @" /* Start PKO 20200428 EXOG-1104_Uniezaleznienie_blokowania_dostawcy_od_godziny_odciecia_zamowienia.docx */
/*AND SOU_FORECAST.get_aval_stock(con.coid,con.scid,p_r_sou_tariff.arid,0) <> 0*/
AND SOU_FORECAST.get_aval_stock(
con.coid,
con.scid ,p_r_sou_tariff . arid,
0 ,
'O' ) <> 0
and costam costam;
/* End PKO 20200428 EXOG-1104_Uniezaleznienie_blokowania_dostawcy_od_godziny_odciecia_zamowienia.docx */";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}