import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "get_aval_stock\\s*\\(\\s*.*\\s*,\\s*.*\\s*,\\s*.*\\s*,\\s*.*\\s*,\\s*'[ANOPZ]'\\s*.*\\)";
final String string = " /* Start PKO 20200428 EXOG-1104_Uniezaleznienie_blokowania_dostawcy_od_godziny_odciecia_zamowienia.docx */\n"
+ " /*AND SOU_FORECAST.get_aval_stock(con.coid,con.scid,p_r_sou_tariff.arid,0) <> 0*/\n"
+ " AND SOU_FORECAST.get_aval_stock(\n"
+ "con.coid,\n"
+ "con.scid ,p_r_sou_tariff . arid,\n"
+ "0 ,\n"
+ "'O' ) <> 0\n"
+ "and costam costam;\n"
+ " /* End PKO 20200428 EXOG-1104_Uniezaleznienie_blokowania_dostawcy_od_godziny_odciecia_zamowienia.docx */";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}