$re = '/get_aval_stock\s*\(\s*.*\s*,\s*.*\s*,\s*.*\s*,\s*.*\s*,\s*\'[ANOPZ]\'\s*.*\)/i';
$str = ' /* Start PKO 20200428 EXOG-1104_Uniezaleznienie_blokowania_dostawcy_od_godziny_odciecia_zamowienia.docx */
/*AND SOU_FORECAST.get_aval_stock(con.coid,con.scid,p_r_sou_tariff.arid,0) <> 0*/
AND SOU_FORECAST.get_aval_stock(
con.coid,
con.scid ,p_r_sou_tariff . arid,
0 ,
\'O\' ) <> 0
and costam costam;
/* End PKO 20200428 EXOG-1104_Uniezaleznienie_blokowania_dostawcy_od_godziny_odciecia_zamowienia.docx */';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);