package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)get_aval_stock\s*\(\s*.*\s*,\s*.*\s*,\s*.*\s*,\s*.*\s*,\s*'[ANOPZ]'\s*.*\)`)
var str = ` /* Start PKO 20200428 EXOG-1104_Uniezaleznienie_blokowania_dostawcy_od_godziny_odciecia_zamowienia.docx */
/*AND SOU_FORECAST.get_aval_stock(con.coid,con.scid,p_r_sou_tariff.arid,0) <> 0*/
AND SOU_FORECAST.get_aval_stock(
con.coid,
con.scid ,p_r_sou_tariff . arid,
0 ,
'O' ) <> 0
and costam costam;
/* End PKO 20200428 EXOG-1104_Uniezaleznienie_blokowania_dostawcy_od_godziny_odciecia_zamowienia.docx */`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}