#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+41|0041|0){1}(\(0\))?[0-9]{2}[\s.-]?[0-9]{3}[\s.-]?[0-9]{2}[\s.-]?[0-9]{2}$"
Local $sString = "0782342323" & @CRLF & _
"0041782342323" & @CRLF & _
"+41782342323" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"078.234.23.23" & @CRLF & _
"004178.234.23.23" & @CRLF & _
"+4178.234.23.23" & @CRLF & _
"" & @CRLF & _
"078-234-23-23" & @CRLF & _
"004178-234-23-23" & @CRLF & _
"+4178-234-23-23" & @CRLF & _
"" & @CRLF & _
"078 234 23 23" & @CRLF & _
"004178 234 23 23" & @CRLF & _
"+4178 234 23 23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")