using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\+41|0041|0){1}(\(0\))?[0-9]{2}[\s.-]?[0-9]{3}[\s.-]?[0-9]{2}[\s.-]?[0-9]{2}$";
string input = @"0782342323
0041782342323
+41782342323
078.234.23.23
004178.234.23.23
+4178.234.23.23
078-234-23-23
004178-234-23-23
+4178-234-23-23
078 234 23 23
004178 234 23 23
+4178 234 23 23";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}