import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\+41|0041|0){1}(\\(0\\))?[0-9]{2}[\\s.-]?[0-9]{3}[\\s.-]?[0-9]{2}[\\s.-]?[0-9]{2}$";
final String string = "0782342323\n"
+ "0041782342323\n"
+ "+41782342323\n\n\n"
+ "078.234.23.23\n"
+ "004178.234.23.23\n"
+ "+4178.234.23.23\n\n"
+ "078-234-23-23\n"
+ "004178-234-23-23\n"
+ "+4178-234-23-23\n\n"
+ "078 234 23 23\n"
+ "004178 234 23 23\n"
+ "+4178 234 23 23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}