re = /(\+41|0041|0){1}(\(0\))?[0-9]{2}[\s.-]?[0-9]{3}[\s.-]?[0-9]{2}[\s.-]?[0-9]{2}$/m
str = '0782342323
0041782342323
+41782342323
078.234.23.23
004178.234.23.23
+4178.234.23.23
078-234-23-23
004178-234-23-23
+4178-234-23-23
078 234 23 23
004178 234 23 23
+4178 234 23 23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end