const regex = /(\+41|0041|0){1}(\(0\))?[0-9]{2}[\s.-]?[0-9]{3}[\s.-]?[0-9]{2}[\s.-]?[0-9]{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\+41|0041|0){1}(\\(0\\))?[0-9]{2}[\\s.-]?[0-9]{3}[\\s.-]?[0-9]{2}[\\s.-]?[0-9]{2}$', 'gm')
const str = `0782342323
0041782342323
+41782342323
078.234.23.23
004178.234.23.23
+4178.234.23.23
078-234-23-23
004178-234-23-23
+4178-234-23-23
078 234 23 23
004178 234 23 23
+4178 234 23 23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}