import re
regex = re.compile(r"(\+41|0041|0){1}(\(0\))?[0-9]{2}[\s.-]?[0-9]{3}[\s.-]?[0-9]{2}[\s.-]?[0-9]{2}$", flags=re.MULTILINE)
test_str = ("0782342323\n"
"0041782342323\n"
"+41782342323\n\n\n"
"078.234.23.23\n"
"004178.234.23.23\n"
"+4178.234.23.23\n\n"
"078-234-23-23\n"
"004178-234-23-23\n"
"+4178-234-23-23\n\n"
"078 234 23 23\n"
"004178 234 23 23\n"
"+4178 234 23 23")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")