#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\b(wood.*?)\b"
Local $sString = "wood and stuff" & @CRLF & _
"this doesnt contain the keyword" & @CRLF & _
"Wooding is what we do"
Local $sSubst = "<span class="highlight">\1</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)