const regex = /\b(wood.*?)\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(wood.*?)\\b', 'gi')
const str = `wood and stuff
this doesnt contain the keyword
Wooding is what we do`;
const subst = `<span class="highlight">\1</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);