re = /\b(wood.*?)\b/i
str = 'wood and stuff
this doesnt contain the keyword
Wooding is what we do'
subst = '<span class="highlight">\\1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result