// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b(wood.*?)\b").unwrap();
let string = "wood and stuff
this doesnt contain the keyword
Wooding is what we do";
let substitution = "<span class=\"highlight\">\\1</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}