using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(wood.*?)\b";
string substitution = @"<span class=""highlight"">\1</span>";
string input = @"wood and stuff
this doesnt contain the keyword
Wooding is what we do";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}