import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(wood.*?)\\b";
final String string = "wood and stuff\n"
+ "this doesnt contain the keyword\n"
+ "Wooding is what we do";
final String subst = "<span class=\"highlight\">\\1</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}