import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([v]{1})(\\d+\\.)(\\d+\\.)(\\*|\\d+)(\\/\\w+\\/)([\\w]+\\/)([\\w]+\\.(?:js|css))";
final String string = "<script type=\"text/javascript\" src=\"assets/v2.2.24/js/main.js?v=5\"></script>\n"
+ "<script type=\"text/javascript\" src=\"assets/v2.2.24/js/dialogs.js?v=5\"></script>\n"
+ "<script type=\"text/javascript\" src=\"assets/v2.2.24/js/maps/main.js?v=5\"></script>\n"
+ " <script type=\"text/javascript\" src=\"assets/v2.2.24/js/maps/dialogs.js?v=5\"></script>\n"
+ "<link rel=\"stylesheet\" href=\"assets/v2.2.24/css/main.css?v=5\">\n"
+ " <link rel=\"stylesheet\" href=\"assets/v2.2.24/css/dialogs.css?v=5\">\n"
+ "<link rel=\"stylesheet\" href=\"assets/v2.2.24/css/maps/main.css?v=5\">\n"
+ " <link rel=\"stylesheet\" href=\"assets/v2.2.24/css/maps/dialogs.css?v=5\">\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}