// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([v]{1})(\d+\.)(\d+\.)(\*|\d+)(\/\w+\/)([\w]+\/)([\w]+\.(?:js|css))").unwrap();
let string = "<script type=\"text/javascript\" src=\"assets/v2.2.24/js/main.js?v=5\"></script>
<script type=\"text/javascript\" src=\"assets/v2.2.24/js/dialogs.js?v=5\"></script>
<script type=\"text/javascript\" src=\"assets/v2.2.24/js/maps/main.js?v=5\"></script>
<script type=\"text/javascript\" src=\"assets/v2.2.24/js/maps/dialogs.js?v=5\"></script>
<link rel=\"stylesheet\" href=\"assets/v2.2.24/css/main.css?v=5\">
<link rel=\"stylesheet\" href=\"assets/v2.2.24/css/dialogs.css?v=5\">
<link rel=\"stylesheet\" href=\"assets/v2.2.24/css/maps/main.css?v=5\">
<link rel=\"stylesheet\" href=\"assets/v2.2.24/css/maps/dialogs.css?v=5\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}