import Foundation
let pattern = #"([v]{1})(\d+\.)(\d+\.)(\*|\d+)(\/\w+\/)([\w]+\/)([\w]+\.(?:js|css))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<script type="text/javascript" src="assets/v2.2.24/js/main.js?v=5"></script>
<script type="text/javascript" src="assets/v2.2.24/js/dialogs.js?v=5"></script>
<script type="text/javascript" src="assets/v2.2.24/js/maps/main.js?v=5"></script>
<script type="text/javascript" src="assets/v2.2.24/js/maps/dialogs.js?v=5"></script>
<link rel="stylesheet" href="assets/v2.2.24/css/main.css?v=5">
<link rel="stylesheet" href="assets/v2.2.24/css/dialogs.css?v=5">
<link rel="stylesheet" href="assets/v2.2.24/css/maps/main.css?v=5">
<link rel="stylesheet" href="assets/v2.2.24/css/maps/dialogs.css?v=5">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)