re = /([v]{1})(\d+\.)(\d+\.)(\*|\d+)(\/\w+\/)([\w]+\/)([\w]+\.(?:js|css))/m
str = '<script type="text/javascript" src="assets/v2.2.24/js/main.js?v=5"></script>
<script type="text/javascript" src="assets/v2.2.24/js/dialogs.js?v=5"></script>
<script type="text/javascript" src="assets/v2.2.24/js/maps/main.js?v=5"></script>
<script type="text/javascript" src="assets/v2.2.24/js/maps/dialogs.js?v=5"></script>
<link rel="stylesheet" href="assets/v2.2.24/css/main.css?v=5">
<link rel="stylesheet" href="assets/v2.2.24/css/dialogs.css?v=5">
<link rel="stylesheet" href="assets/v2.2.24/css/maps/main.css?v=5">
<link rel="stylesheet" href="assets/v2.2.24/css/maps/dialogs.css?v=5">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end