import re
regex = re.compile(r"([v]{1})(\d+\.)(\d+\.)(\*|\d+)(\/\w+\/)([\w]+\/)([\w]+\.(?:js|css))", flags=re.MULTILINE)
test_str = ("<script type=\"text/javascript\" src=\"assets/v2.2.24/js/main.js?v=5\"></script>\n"
"<script type=\"text/javascript\" src=\"assets/v2.2.24/js/dialogs.js?v=5\"></script>\n"
"<script type=\"text/javascript\" src=\"assets/v2.2.24/js/maps/main.js?v=5\"></script>\n"
" <script type=\"text/javascript\" src=\"assets/v2.2.24/js/maps/dialogs.js?v=5\"></script>\n"
"<link rel=\"stylesheet\" href=\"assets/v2.2.24/css/main.css?v=5\">\n"
" <link rel=\"stylesheet\" href=\"assets/v2.2.24/css/dialogs.css?v=5\">\n"
"<link rel=\"stylesheet\" href=\"assets/v2.2.24/css/maps/main.css?v=5\">\n"
" <link rel=\"stylesheet\" href=\"assets/v2.2.24/css/maps/dialogs.css?v=5\">\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")