const regex = /([v]{1})(\d+\.)(\d+\.)(\*|\d+)(\/\w+\/)([\w]+\/)([\w]+\.(?:js|css))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([v]{1})(\\d+\\.)(\\d+\\.)(\\*|\\d+)(\\\/\\w+\\\/)([\\w]+\\\/)([\\w]+\\.(?:js|css))', 'gm')
const str = `<script type="text/javascript" src="assets/v2.2.24/js/main.js?v=5"></script>
<script type="text/javascript" src="assets/v2.2.24/js/dialogs.js?v=5"></script>
<script type="text/javascript" src="assets/v2.2.24/js/maps/main.js?v=5"></script>
<script type="text/javascript" src="assets/v2.2.24/js/maps/dialogs.js?v=5"></script>
<link rel="stylesheet" href="assets/v2.2.24/css/main.css?v=5">
<link rel="stylesheet" href="assets/v2.2.24/css/dialogs.css?v=5">
<link rel="stylesheet" href="assets/v2.2.24/css/maps/main.css?v=5">
<link rel="stylesheet" href="assets/v2.2.24/css/maps/dialogs.css?v=5">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}