use strict;
my $str = '<script type="text/javascript" src="assets/v2.2.24/js/main.js?v=5"></script>
<script type="text/javascript" src="assets/v2.2.24/js/dialogs.js?v=5"></script>
<script type="text/javascript" src="assets/v2.2.24/js/maps/main.js?v=5"></script>
<script type="text/javascript" src="assets/v2.2.24/js/maps/dialogs.js?v=5"></script>
<link rel="stylesheet" href="assets/v2.2.24/css/main.css?v=5">
<link rel="stylesheet" href="assets/v2.2.24/css/dialogs.css?v=5">
<link rel="stylesheet" href="assets/v2.2.24/css/maps/main.css?v=5">
<link rel="stylesheet" href="assets/v2.2.24/css/maps/dialogs.css?v=5">
';
my $regex = qr/([v]{1})(\d+\.)(\d+\.)(\*|\d+)(\/\w+\/)([\w]+\/)([\w]+\.(?:js|css))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}