#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\S*['’]\S*\h*"
Local $sString = "'Tis midnight" & @CRLF & _
"sev'n words spoke" & @CRLF & _
"th'Immortal night" & @CRLF & _
"A wonder-working pow'r" & @CRLF & _
"Wondrous deliv'rer to me"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)