$re = '/\S*[\'’]\S*\h*/m';
$str = '\'Tis midnight
sev\'n words spoke
th\'Immortal night
A wonder-working pow\'r
Wondrous deliv\'rer to me';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;