const regex = /\S*['’]\S*\h*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S*[\'’]\\S*\\h*', 'gm')
const str = `'Tis midnight
sev'n words spoke
th'Immortal night
A wonder-working pow'r
Wondrous deliv'rer to me`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);