re = /\S*['’]\S*\h*/m
str = '\'Tis midnight
sev\'n words spoke
th\'Immortal night
A wonder-working pow\'r
Wondrous deliv\'rer to me'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result