use strict;
my $str = '\'Tis midnight
sev\'n words spoke
th\'Immortal night
A wonder-working pow\'r
Wondrous deliv\'rer to me';
my $regex = qr/\S*['’]\S*\h*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";