import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S*['’]\\S*\\h*";
final String string = "'Tis midnight\n"
+ "sev'n words spoke\n"
+ "th'Immortal night\n"
+ "A wonder-working pow'r\n"
+ "Wondrous deliv'rer to me";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}