package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S*['’]\S*\h*`)
var str = `'Tis midnight
sev'n words spoke
th'Immortal night
A wonder-working pow'r
Wondrous deliv'rer to me`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}