#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*?\s*\|\s*(.*?)\s*\|.*"
Local $sString = "Live => [US] United States | example1@yahoo.com | Checked on 5:59 pm - May 17, 2015 " & @CRLF & _
"Live => [US] United States | example2@yahoo.com | Checked on 5:59 pm - May 17, 2015 " & @CRLF & _
"Live => [US] United States | example3@yahoo.com | Checked on 5:59 pm - May 17, 2015 " & @CRLF & _
"Live => [US] United States | example4@yahoo.com | Checked on 5:59 pm - May 17, 2015 " & @CRLF & _
"Live => [US] United States | example5@yahoo.com | Checked on 5:59 pm - May 17, 2015 "
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)