using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?\s*\|\s*(.*?)\s*\|.*";
string substitution = @"$1";
string input = @"Live => [US] United States | example1@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example2@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example3@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example4@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example5@yahoo.com | Checked on 5:59 pm - May 17, 2015 ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}