import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?\\s*\\|\\s*(.*?)\\s*\\|.*";
final String string = "Live => [US] United States | example1@yahoo.com | Checked on 5:59 pm - May 17, 2015 \n"
+ "Live => [US] United States | example2@yahoo.com | Checked on 5:59 pm - May 17, 2015 \n"
+ "Live => [US] United States | example3@yahoo.com | Checked on 5:59 pm - May 17, 2015 \n"
+ "Live => [US] United States | example4@yahoo.com | Checked on 5:59 pm - May 17, 2015 \n"
+ "Live => [US] United States | example5@yahoo.com | Checked on 5:59 pm - May 17, 2015 ";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}