re = /.*?\s*\|\s*(.*?)\s*\|.*/
str = 'Live => [US] United States | example1@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example2@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example3@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example4@yahoo.com | Checked on 5:59 pm - May 17, 2015
Live => [US] United States | example5@yahoo.com | Checked on 5:59 pm - May 17, 2015 '
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result